Slow or Intermittent Loading

Incident Report for CourtReserve

Resolved

Operations have continued in normal order for 2.5 hours.
Posted Jul 08, 2025 - 15:10 EDT

Update

The loading issue lasted for about 15 minutes and then subsided. Everything has now been stable for 45 minutes. We are continuing to investigate the issue to determine a cause and will continue monitoring performance closely.
Posted Jul 08, 2025 - 13:25 EDT

Investigating

We are currently investigating slow or intermittent loading, including the Scheduler loading blank.
Posted Jul 08, 2025 - 12:38 EDT
This incident affected: Website: courtreserve.com, Desktop Application: app.courtreserve.com, Mobile Application, Rest API: api.courtreserve.com, and SafeSave Payments.